Not joined yet? Register for free and enjoy features such as alerts, private messaging and viewing latest posts and topics.

Air-con not getting cold

Post Reply
iamwestone
Newbie
Newbie
Posts: 5
Joined: Mon May 06, 2024 5:18 pm

Air-con not getting cold

Post by iamwestone » Mon May 06, 2024 6:00 pm

I have a 2017 F15. Last summer the aircon wasn't blowing cold so a mobile company came out and re-gassed the system and it worked ok for a few weeks but then it went back to how it was. I don't want to take it to a BMW dealership but nobody else seems to want to look at it. Is this something I can potentially do myself?

IanP
Member
Member
Posts: 494
Joined: Tue Aug 31, 2010 6:59 am

Air-con not getting cold

Post by IanP » Mon May 06, 2024 7:34 pm

Sounds like a system leak. Any good air con company should be able to put fluorescent dye into the system to find any problems before putting expensive gas back in

User avatar
X5Sport
Global Moderator
Global Moderator
Posts: 18648
Joined: Fri Sep 03, 2010 4:09 pm
Location: Planet X6......

Air-con not getting cold

Post by X5Sport » Mon May 06, 2024 7:44 pm

I agree, sounds as if something is leaking. A dye trace is probably the only sensible way to find it.

Do you run it all year around? One of the issues with modern refrigerants is they must have lubricant added during regassing and it’s key to keeping the seals healthy. Advice I’ve had ever since my E53 was just put the AC on auto and leave it. It makes very little difference to fuel consumption (especially on the larger engines). You can get kits from motor factors that include a pressure gauge (I bought mine from Halfords years ago) however refrigerants have changed since then and I can’t mix them. I’m not even sure the fittings match! Top up canisters should include lubricant though the system is only supposed to contain a specific amount and if you’re losing gas then you may not be losing lubricant and end up with too much.
:ant: Never anthropomorphise computers. They hate that.

H4MP
Member
Member
Posts: 168
Joined: Thu Jul 12, 2018 1:36 am

Air-con not getting cold

Post by H4MP » Mon Jun 10, 2024 11:56 pm

If it works for a few weeks and then stopped, this means you have a leak. Most likely it's the condenser.
This happened to me on my Ford Focus.

Post Reply