Xdrivers has re-branded as xseries-forum. You will need to login again (with the same credentials as XDrivers) If you are experiencing trouble logging in please email admin@xseries-forum.com. Also, please check your junk mail for any forum notifications

Engine cutting out 3.0sd

Discuss the problems with your BMW X5 (E70).
Post Reply
b21playa
Member
Member
Posts: 87
Joined: Wed Nov 03, 2010 9:00 am

Engine cutting out 3.0sd

Post by b21playa » Fri May 07, 2021 10:07 am

Hi all

Today after setting out (engine was warm) the engine cut out randomly. Trying to start it didn’t do anything, I had to remove key and then try again when it started. Managed to nurse it home as I was only up the road and checked fault codes when I got back. Only code was 4440 injector cylinder 4 activation. Code cleared fine and car started ok.

I ran a smoothness test and all values within spec. Any ideas what could be causing this as I don’t want it happening again when I’m further from home or on the way to work.

Thanks in advance

User avatar
X5Sport
Global Moderator
Global Moderator
Posts: 17256
Joined: Fri Sep 03, 2010 4:09 pm
Location: Planet X6......

Re: Engine cutting out 3.0sd

Post by X5Sport » Fri May 07, 2021 1:01 pm

Look for signs of water around the injector connector(s). It could be damp affecting the injector wiring. I found the error doing an on line search.
:ant: Never anthropomorphise computers. They hate that.

b21playa
Member
Member
Posts: 87
Joined: Wed Nov 03, 2010 9:00 am

Re: Engine cutting out 3.0sd

Post by b21playa » Fri May 07, 2021 1:47 pm

I’ve taken air ox off and there was no signs of water. Luckily I could get the connector off without removing manifold and it looked fine and tested ok for continuity.

User avatar
X5Sport
Global Moderator
Global Moderator
Posts: 17256
Joined: Fri Sep 03, 2010 4:09 pm
Location: Planet X6......

Re: Engine cutting out 3.0sd

Post by X5Sport » Fri May 07, 2021 5:59 pm

If the wiring all looks ok and no sign of damp/water or gunk in the connections, plus a physical check further back along the loom also looks OK (no cracked wires etc) then the issue has to be at one end of the wire or the other. That I think means injector or whatever controls it. With any luck the fact that you’ve removed and refitted the connector might solve the problem :thumbsup:
:ant: Never anthropomorphise computers. They hate that.

b21playa
Member
Member
Posts: 87
Joined: Wed Nov 03, 2010 9:00 am

Re: Engine cutting out 3.0sd

Post by b21playa » Fri May 07, 2021 7:18 pm

X5Sport wrote: Fri May 07, 2021 5:59 pm If the wiring all looks ok and no sign of damp/water or gunk in the connections, plus a physical check further back along the loom also looks OK (no cracked wires etc) then the issue has to be at one end of the wire or the other. That I think means injector or whatever controls it. With any luck the fact that you’ve removed and refitted the connector might solve the problem :thumbsup:
My 535d had the wiring on the top of the manifold which was easier to check. The e70 goes underneath. I’ll see how it goes over the next week or so, if not I guess I’ll be taking inlet off to check resistance on each plug and injector

User avatar
Alan Gunn
Snr Member
Snr Member
Posts: 1084
Joined: Thu Dec 08, 2016 10:32 pm
Location: Anglesey North Wales

Re: Engine cutting out 3.0sd

Post by Alan Gunn » Sat May 08, 2021 6:14 am

I had the crack wire problem you talk about but i got 4 codes 1 for each injector and was hard to locate.
My car would not start at all.
When you restarted the car did it run smooth.

b21playa
Member
Member
Posts: 87
Joined: Wed Nov 03, 2010 9:00 am

Re: Engine cutting out 3.0sd

Post by b21playa » Sat May 08, 2021 10:44 am

Hoping mine was just a one off (fingers crossed)

b21playa
Member
Member
Posts: 87
Joined: Wed Nov 03, 2010 9:00 am

Re: Engine cutting out 3.0sd

Post by b21playa » Sun May 09, 2021 1:23 pm

Alan Gunn wrote: Sat May 08, 2021 6:14 am I had the crack wire problem you talk about but i got 4 codes 1 for each injector and was hard to locate.
My car would not start at all.
When you restarted the car did it run smooth.
Did you replace loom to fix?

User avatar
Alan Gunn
Snr Member
Snr Member
Posts: 1084
Joined: Thu Dec 08, 2016 10:32 pm
Location: Anglesey North Wales

Re: Engine cutting out 3.0sd

Post by Alan Gunn » Mon May 10, 2021 6:34 am

b21playa wrote: Sun May 09, 2021 1:23 pm
Alan Gunn wrote: Sat May 08, 2021 6:14 am I had the crack wire problem you talk about but i got 4 codes 1 for each injector and was hard to locate.
My car would not start at all.
When you restarted the car did it run smooth.
Did you replace loom to fix?
No i repaired the wire and then put plenty of tape round them all where i thought they might rub.

b21playa
Member
Member
Posts: 87
Joined: Wed Nov 03, 2010 9:00 am

Re: Engine cutting out 3.0sd

Post by b21playa » Mon May 10, 2021 7:54 am

Alan Gunn wrote: Mon May 10, 2021 6:34 am
b21playa wrote: Sun May 09, 2021 1:23 pm
Alan Gunn wrote: Sat May 08, 2021 6:14 am I had the crack wire problem you talk about but i got 4 codes 1 for each injector and was hard to locate.
My car would not start at all.
When you restarted the car did it run smooth.
Did you replace loom to fix?
No i repaired the wire and then put plenty of tape round them all where i thought they might rub.
Where did you track the break in the wire to?

b21playa
Member
Member
Posts: 87
Joined: Wed Nov 03, 2010 9:00 am

Re: Engine cutting out 3.0sd

Post by b21playa » Mon May 10, 2021 10:56 am

Anyone know it it’s possible to remove injector 4 without removing manifold? It’s the only one that looks like it could be possible (maybe with a little trim of manifold). I remember doing something similar years ago in a 535d

Thanks

User avatar
marti
Member
Member
Posts: 660
Joined: Tue Jan 19, 2016 11:33 am
Location: Norfolk

Re: Engine cutting out 3.0sd

Post by marti » Mon May 10, 2021 5:07 pm

b21playa wrote: Mon May 10, 2021 10:56 am Anyone know it it’s possible to remove injector 4 without removing manifold? It’s the only one that looks like it could be possible (maybe with a little trim of manifold). I remember doing something similar years ago in a 535d

Thanks
Its just as easy to remove the manifold, it doesn't take long, It normally takes me 1/2 to 3/4's of an hour and then everything is easier to get at, I forget which side now but one side has captive bolts and the other has nuts (E-series, F have all captive) which can be dropped easily, so undo them until they are nearly off and use a telescopic magnet to do the final couple of turns a big rag or cloth underneath the side of the manifold is a good idea in case you drop one....Im Sure they are 11mm and while your at it delete the swirl flaps and you can give the manifold a good clean out :D

b21playa
Member
Member
Posts: 87
Joined: Wed Nov 03, 2010 9:00 am

Re: Engine cutting out 3.0sd

Post by b21playa » Mon May 10, 2021 5:16 pm

marti wrote: Mon May 10, 2021 5:07 pm
b21playa wrote: Mon May 10, 2021 10:56 am Anyone know it it’s possible to remove injector 4 without removing manifold? It’s the only one that looks like it could be possible (maybe with a little trim of manifold). I remember doing something similar years ago in a 535d

Thanks
Its just as easy to remove the manifold, it doesn't take long, It normally takes me 1/2 to 3/4's of an hour and then everything is easier to get at, I forget which side now but one side has captive bolts and the other has nuts (E-series, F have all captive) which can be dropped easily, so undo them until they are nearly off and use a telescopic magnet to do the final couple of turns a big rag or cloth underneath the side of the manifold is a good idea in case you drop one....Im Sure they are 11mm and while your at it delete the swirl flaps and you can give the manifold a good clean out :D
Just trying to avoid removing manifold, I know it doesn’t take long just anything to save doing it. Already had it off before when I did swirl flaps, glow plugs & controller as well as vacuum hoses. 10mm are captive at the top and 11mm nuts aren’t 😀

b21playa
Member
Member
Posts: 87
Joined: Wed Nov 03, 2010 9:00 am

Re: Engine cutting out 3.0sd

Post by b21playa » Fri May 14, 2021 1:21 pm

Swapped out injector 4 this morning and drove the car for 40mins and didn’t cut out. Hopefully this has sorted out the issue

Post Reply