If you are experiencing trouble logging in please email admin@xseries-forum.com. Also, please check your junk mail for any forum notifications (and add admin@xseries-forum.com as a contact to avoid mail going to spam)

Weird one..

Post Reply
M50dG05
Newbie
Newbie
Posts: 22
Joined: Wed Jul 07, 2021 7:48 am

Weird one..

Post by M50dG05 » Sat Jul 10, 2021 10:54 pm

Have my phone paired to the car, also now on Android auto after the OTA update - But, whenever I unlock the car after it's been stood for maybe a couple of hours - I get the following message flash up on the 6wb..

"please set time and date in the vehicle"

Sure enough, if I power on, the date is correct, but the time is out by a few hrs & mins - UNTIL the phone connects to BT etc, and then the time and date is correct...

I've checked the regional/dst settings, and also have "auto update time" checked - and obv the car has an online data subs as it's only 9 months old..

Anyone?

Online
User avatar
X5Sport
Global Moderator
Global Moderator
Posts: 17303
Joined: Fri Sep 03, 2010 4:09 pm
Location: Planet X6......

Weird one..

Post by X5Sport » Sun Jul 11, 2021 7:40 am

Date and time in my F46 comes from the GPS signal. I’ve never had to set it (even for the Summer/Winter time shifts) since owning the car. It is fitted with the top level whatever generation iDrive came out in 2018. Yours may be slightly different?

My iDrive settings are:
‘My Vehicle’ Menu > ‘iDrive Settings’ > ‘Date & Time’ > select ‘Automatic time setting’.

If that doesn’t work then computers aren’t talking to each other nicely :x

M50dG05
Newbie
Newbie
Posts: 22
Joined: Wed Jul 07, 2021 7:48 am

Weird one..

Post by M50dG05 » Sun Jul 11, 2021 5:55 pm

Automatic time setting is enabled, already checked that. Just admitting that it bongs when door opened and puts message on cluster. One I start and the phone is connected via WiFi and bt, time updates automatically..

Hmm..

Online
User avatar
X5Sport
Global Moderator
Global Moderator
Posts: 17303
Joined: Fri Sep 03, 2010 4:09 pm
Location: Planet X6......

Weird one..

Post by X5Sport » Sun Jul 11, 2021 6:01 pm

Wierd one. The F46 doesn’t care whether there’s a phone there or not as it doesn’t use the phones for the clock. Intrigued.
:ant: Never anthropomorphise computers. They hate that.

M50dG05
Newbie
Newbie
Posts: 22
Joined: Wed Jul 07, 2021 7:48 am

Weird one..

Post by M50dG05 » Mon Jul 12, 2021 7:56 am

X5Sport wrote: Sun Jul 11, 2021 6:01 pm Wierd one. The F46 doesn’t care whether there’s a phone there or not as it doesn’t use the phones for the clock. Intrigued.
Yup, that's my thoughts, the car should get the time settings from either it's own GPS and/or online connection... More tinkering required once I get the paper manual, cba scrolling through the pdf/idrive 😁

M50dG05
Newbie
Newbie
Posts: 22
Joined: Wed Jul 07, 2021 7:48 am

Weird one..

Post by M50dG05 » Sat Jul 17, 2021 9:37 am

Ok, so borrowed a friend's Snap On kit yesterday, and car has a fault!!

"B7F6A3 Instrument panel: Voltage supply, terminal 30 failed"

So, I guess that's why it's losing it's time & date when left for 30 mins or so..

Phone call to BMW imminent - Not a good show @ less than 8,000 mile and 10 months old!

sapphireblack
Member
Member
Posts: 929
Joined: Mon Apr 18, 2011 8:30 am
Location: Kent & Zakynthos (Greece)

Weird one..

Post by sapphireblack » Sat Jul 17, 2021 11:45 am

Oh dear.

Don't doubt your dealer will sort it but a bad show on a near new, ex DP car. I hope they are suitably embarrassed and equally offer suitable recompense for the hassle.

Online
User avatar
X5Sport
Global Moderator
Global Moderator
Posts: 17303
Joined: Fri Sep 03, 2010 4:09 pm
Location: Planet X6......

Weird one..

Post by X5Sport » Sat Jul 17, 2021 11:59 am

They should have done a diagnostic check before handover! That being said, the PDI for my F46 wasn’t done correctly and even though I handed over the diagnostic list, the dealer just wasn’t interested until it came in for a major service - and that hasn’t happened yet - so it didn’t get dealt with until the end of warranty check just before three years.

The same dealer wants to do a deal to get this car back earlier and sell me a new one so I’ve said well go on then, impress me. Complete and utter silence ensues.

Having had similar experiences with GM, VW, Audi, Merc and Škoda, I’m assuming it’s an industry wide problem. It isn’t good enough but there’s just no comeback.
:ant: Never anthropomorphise computers. They hate that.

M50dG05
Newbie
Newbie
Posts: 22
Joined: Wed Jul 07, 2021 7:48 am

Weird one..

Post by M50dG05 » Fri Jul 23, 2021 9:04 am

Well, and it's having a new cluster fitted this afternoon - Dread to think what that would cost out of warranty!!

Hopefully problem solved!

sapphireblack
Member
Member
Posts: 929
Joined: Mon Apr 18, 2011 8:30 am
Location: Kent & Zakynthos (Greece)

Weird one..

Post by sapphireblack » Sat Jul 24, 2021 8:06 am

Slapped wrist for the dealership then. DP probably far to busy to have even noticed  :roll: although it should have been found before it was sold to you.
Last edited by sapphireblack on Sun Jul 25, 2021 9:26 am, edited 1 time in total.

Post Reply