Not joined yet? Register for free and enjoy features such as alerts, private messaging and viewing latest posts and topics.

X5 06 Auto 4.4 constantly slipping in and out of gear

Discuss the problems with your X5 (E53).
Post Reply
Mossy
Newbie
Newbie
Posts: 5
Joined: Fri Dec 24, 2021 11:20 am

X5 06 Auto 4.4 constantly slipping in and out of gear

Post by Mossy » Tue Aug 02, 2022 12:00 pm

This problem started about a year ago, the engine would surge when in park.

Then it would 'clunk' when gears changing.

Was advised to change mechatronic which made no difference after a couple of weeks.

I had the new mechatronic unit checked and results said it was ok.

Strange thing is, it drives smoothly for about 20 minutes and then it just constantly surges, stutters, slips in and out of gear and loses power in safe mode.

Other faults showing up are:

DME-ME922 Engine electronics
EGS
ABS-DSC
IKE
IHKA
LCM-IV
PDC2
It is virtually undrivable now and I need some help!

User avatar
X5Sport
Global Moderator
Global Moderator
Posts: 17826
Joined: Fri Sep 03, 2010 4:09 pm
Location: Planet X6......

X5 06 Auto 4.4 constantly slipping in and out of gear

Post by X5Sport » Tue Aug 02, 2022 6:38 pm

Hello and welcome.

You need to get a full transmission diagnostics check to see the exact codes. It sounds like gearbox once it warms up.

The errors you have above are connected to - and we need the actual codes (preferably not ‘P’ codes as those are generic OBD2 rather than specific for BMW.

DME - Digital Motor Electronics - engine computer fault
EGS - that’s the transmission
ABS-DSC - anti-lock brakes and dynamic stability control issue
IKE - could just be the scanner not communicating correctly
IHKA - climate control module issue
LCM-IV - lighting control module issue
PDC2 - parking sensor issue.

Have you tried clearing the error log and seeing what comes back? Does your scan say they are ‘current’ as in there now, or are they historic?
:ant: Never anthropomorphise computers. They hate that.

Mossy
Newbie
Newbie
Posts: 5
Joined: Fri Dec 24, 2021 11:20 am

X5 06 Auto 4.4 constantly slipping in and out of gear

Post by Mossy » Tue Aug 02, 2022 7:49 pm

Thanks for the feedback.
I have attached the full report. Does this have the detail and accuracy needed?
These are also the dashboard lights that show when going into safe mode.
Next steps?
Attachments
Fault report jpg0004.jpg
Fault report jpg0004.jpg (41.74 KiB) Viewed 224 times
Fault report jpg0003.jpg
Fault report jpg0003.jpg (66.78 KiB) Viewed 224 times
Fault report jpg0002.jpg
Fault report jpg0002.jpg (71.27 KiB) Viewed 224 times
Fault report jpg0001.jpg
Fault report jpg0001.jpg (54.34 KiB) Viewed 224 times

User avatar
X5Sport
Global Moderator
Global Moderator
Posts: 17826
Joined: Fri Sep 03, 2010 4:09 pm
Location: Planet X6......

X5 06 Auto 4.4 constantly slipping in and out of gear

Post by X5Sport » Tue Aug 02, 2022 10:00 pm

I think the ‘absent’ errors are those stored in memory from previous. If the error code log is cleared and they return then those one are ‘present’ and still triggering.

DME looks like one of the thermostats is stuck - probably open. Common fault so the engine runs cooler. That wouldn’t cause a gear problem though.

I get the Aux pump error on mine, always have and it just means the Aux Heating isn’t working…..it isn’t fitted in my case.

It could be an oil pressure issue within the box itself once it warms up. Hard to say but things to look at would be the box itself (clutch or brake packs), torque converter, transfer box.

If it’s had a transmission oil change, what state (colour/smell) was it in? Dark, burnt smelling oil means trouble within the box itself. The Mechatronics unit is just the brain controlling the hydraulics.
:ant: Never anthropomorphise computers. They hate that.

Mossy
Newbie
Newbie
Posts: 5
Joined: Fri Dec 24, 2021 11:20 am

X5 06 Auto 4.4 constantly slipping in and out of gear

Post by Mossy » Mon Aug 08, 2022 4:51 pm

Thanks for the update.

The position now is that changing the mechatronics has made no difference, same faults are coming up.
The car is still with the garage. They have recommended the change to the mechatronics but its obviously £2k wasted.
Whose liability is it now when they came back and say new or repaired gearbox?

Themoog2
Member
Member
Posts: 452
Joined: Sun Nov 25, 2018 10:29 pm
Location: Cambridge

X5 06 Auto 4.4 constantly slipping in and out of gear

Post by Themoog2 » Mon Aug 08, 2022 10:16 pm

Has anyone does a trans fluid service on it? That would be my first option then go from there. That's experience talking too.. Yes it may be £300 but if it works then it's cheaper than £2k for a trans rebuild and only £300 more if it does need a trans rebuild. My logic seems a bit odd I know but that's the way to go in my opinion.

Post Reply